温馨提示:本文翻译自stackoverflow.com,查看原文请点击:reactjs - I can't build my react with boostrap problem about css-loader
bootstrap-4 css reactjs webpack webpack-4

reactjs - 我无法建立关于css-loader的boostrap问题的反应

发布于 2020-03-31 23:30:00

我的反应index.js导入引导程序,我使用Webpack 4

import React from 'react';
import ReactDOM from 'react-dom';
import './assets/css/index.css';
import App from './App';
import * as serviceWorker from './serviceWorker';
import 'bootstrap/dist/css/bootstrap.min.css';

ReactDOM.render(<App />, document.getElementById('root'));

serviceWorker.unregister();

当我运行生成时,此错误消息

./node_modules/bootstrap/dist/css/bootstrap.min.css中的错误6:3
模块解析失败:意外的令牌(6:3)
您可能需要适当的加载程序来处理此文件类型,当前未配置任何加载程序来处理这个文件。参见 https://webpack.js.org/concepts#loaders

module: {
   ...
   {
      test: /\.css$/,
      exclude: /(node_modules)/,
      use: ['style-loader', 'css-loader'],
   },
   ...
}

感谢您的帮助。

查看更多

提问者
TSCH
被浏览
51
Prakash Karena 2020-01-31 20:25

您排除导致此问题的node_modules,将其从wabpack配置中删除。

module: {
   ...
   {
      test: /\.css$/,
      use: ['style-loader', 'css-loader']
   },
   ...
}

最新帖子

最新文章