温馨提示:本文翻译自stackoverflow.com,查看原文请点击:tensorflow2.0 - Could not load dynamic library 'cudart64_101.dll' on tensorflow CPU-only installation
tensorflow tensorflow2.0

tensorflow2.0 - 无法在仅Tensorflow CPU的安装上加载动态库'cudart64_101.dll'

发布于 2020-04-11 23:58:35

我刚刚通过安装了Tensorflow的最新版本,pip install tensorflow并且每当我运行一个程序时,都会收到日志消息:

W tensorflow / stream_executor / platform / default / dso_loader.cc:55]无法加载动态库'cudart64_101.dll';dlerror:找不到cudart64_101.dll

这不好吗?如何解决错误?

查看更多

提问者
GPhilo
被浏览
24
GPhilo 2020-03-12 23:32

Tensorflow 2.1+

这是怎么回事?

新的Tensorflow 2.1版本中,默认的tensorflowpip包同时包含CPU和GPU版本的TF。在以前的TF版本中,未找到CUDA库会发出错误并引发异常,而现在库会从动力学上搜索正确的CUDA版本,如果找不到,则会发出警告(开头W代表对于警告,错误具有E对于致命错误则为F),并退回到仅CPU模式。实际上,警告之后,错误消息也作为信息消息写在日志中(请注意,如果警告级别更高,最低日志级别(默认),您可能看不到信息消息。完整日志为(强调我的):

2020-01-20 12:27:44.554767:W tensorflow / stream_executor / platform / default / dso_loader.cc:55]无法加载动态库'cudart64_101.dll';dlerror:找不到cudart64_101.dll

2020-01-20 12:27:44.554964:I tensorflow / stream_executor / cuda / cudart_stub.cc:29] 如果您的计算机上未设置GPU,请忽略cudart dlerror。

我应该担心吗?我如何解决它?

如果您的计算机上没有启用CUDA的GPU,或者您不关心没有GPU加速,则无需担心。另一方面,如果您安装了tensorflow并希望GPU加速,请检查您的CUDA安装(TF 2.1需要CUDA 10.1而不是 10.2或10.0)。

如果您只想摆脱警告,则可以调整TF的日志记录级别来抑制警告,但这可能会过大,因为它将使所有警告静音


Tensorflow 1.X或2.0:

您的CUDA设置已损坏,请确保安装了正确的版本。

最新帖子

最新文章