温馨提示:本文翻译自stackoverflow.com,查看原文请点击:其他 - Error: Unable to resolve module `react` from `index.js`: react could not be found within the project

其他 - 错误:无法从index.js中解析模块react:在项目中找不到反应

发布于 2020-03-27 16:08:26

错误:无法reactindex.js以下项目解析模块:在项目中找不到react。

当我尝试运行我的项目时,它将给我这个捆绑失败的错误。

在此处输入图片说明

这是我的index.js文件代码。

/**
 * @format
 */
import React,{Component} from 'react';
import {AppRegistry} from 'react-native';
import {name as appName} from './app.json';
import src from './Screens/Search'
import AppContainer from "./Component/MainNavigation";
class myApp extends Component {
    render(){
        return(
            <AppContainer />
        )
    }

}
AppRegistry.registerComponent(appName, () => myApp);

package.json文件。

{
  "name": "CharityDating",
  "version": "0.0.1",
  "private": true,
  "scripts": {
    "android": "react-native run-android",
    "ios": "react-native run-ios",
    "start": "react-native start",
    "test": "jest",
    "lint": "eslint ."
  },
  "dependencies": {
    "@ptomasroos/react-native-multi-slider": "^1.0.0",
    "@react-native-community/masked-view": "^0.1.6",
    "react": "16.9.0",
    "react-native": "^0.61.5",
    "react-native-animatable": "^1.3.3",
    "react-native-country-picker-modal": "^1.10.0",
    "react-native-datepicker": "^1.7.2",
    "react-native-draggable": "^3.0.0",
    "react-native-draggable-grid": "^1.2.1",
    "react-native-gesture-handler": "^1.5.3",
    "react-native-image-picker": "^2.0.0",
    "react-native-image-slider": "^2.0.3",
    "react-native-keyboard-aware-scrollview": "^2.1.0",
    "react-native-pulse": "^1.0.7",
    "react-native-reanimated": "^1.7.0",
    "react-native-responsive-fontsize": "^0.4.2",
    "react-native-responsive-screen": "^1.3.1",
    "react-native-safe-area-context": "^0.6.2",
    "react-native-safe-area-view": "^1.0.0",
    "react-native-slider": "^0.11.0",
    "react-native-sortable-grid": "^2.0.0",
    "react-native-switch-toggle": "^1.1.4",
    "react-navigation": "^4.0.10",
    "react-navigation-stack": "^2.0.13",
    "react-navigation-tabs": "^2.7.0",
    "react-toggle": "^4.1.1",
    "responsive-image": "^0.3.1",
    "toggle-switch-react-native": "^2.1.0"
  },
  "devDependencies": {
    "@babel/core": "^7.6.2",
    "@babel/runtime": "^7.6.2",
    "@react-native-community/eslint-config": "^0.0.5",
    "babel-jest": "^24.9.0",
    "eslint": "^6.5.1",
    "jest": "^24.9.0",
    "metro-react-native-babel-preset": "^0.56.0",
    "react-test-renderer": "16.9.0"
  },
  "jest": {
    "preset": "react-native"
  }
}

查看更多

查看更多

提问者
Raghu singh
被浏览
54
Raghu singh 2020-01-31 17:53

我再次安装了react再次使用'npm i react'解决了错误。

发布
问题

分享
好友

手机
浏览

扫码手机浏览