backpack - 🎒新一代加密钱包

Created at: 2022-02-24 22:35:47
开发语言: TypeScript
授权协议: NOASSERTION

背包

你的异性恋物之家

构建状态 教程 不和谐聊天

注意

  • 背包正在积极开发中,因此所有 API 都可能发生变化。
  • 此代码未经审计。使用风险自负。
  • 我再说一遍。这还没有准备好生产。

安装最新版本

如果要安装最新的开发人员版本,请使用开发人员模式获取最新版本.zip此处,然后将其添加到本地 chrome 配置文件中。请观看以下视频。

本地开发

https://user-images.githubusercontent.com/101902546/173857300-fc139113-0af5-46fc-baad-236a2ebf63f1.m4p

0. 拉取代码

git clone git@github.com:coral-xyz/backpack.git
git submodule init
git submodule update

1. 临时预备步骤

启用自签名本地 SSL 证书

前往 chrome://flags/#allow-insecure-localhost 并启用切换开关,然后重新启动镶边。注意:如果你不知道自己在做什么,请不要启用此功能。如果继续使用,它将使你容易受到攻击。建议在完成开发后撤消此步骤。

环境变量

你还可以选择重命名为并设置自己的变量。

.env.example
.env

2. 安装依赖项

yarn install

3. 构建用于生产的所有软件包

yarn build

4. 启动用于开发的包

yarn start

注意:在新的存储库中,应在 之前运行。

yarn build
yarn start

如果你在构建时遇到问题,请尝试将纱线运行干净,然后重新开始。

5一.安装扩展的开发版本

转到 chrome://extensions,启用开发人员模式(右上角)并将目录拖到窗口中。此版本将在标题中包含(Dev),并支持实时重新加载。

packages/app-extension/dev

5b.(可选)安装构建的扩展

如果要尝试扩展的生产版本,请运行该目录并将其拖动到 chrome://extensions 中,如上所述。此版本不会有热重载,除非你还运行,否则本地插件将不可见

yarn build
packages/app-extension/build
yarn start

许可证

除非你另有明确说明,否则你有意提交以供包含的任何贡献应由存储库维护者自行决定许可,而无需任何附加条款或条件。